#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\[CDATA\[\[[^]*?]]>"
Local $sString = "<records>" & @CRLF & _
" <record>" & @CRLF & _
" <name>Jon</name>" & @CRLF & _
" <surname>Doe</surname>" & @CRLF & _
" <dob>2001-02-01</dob>" & @CRLF & _
" <comment>" & @CRLF & _
" <![CDATA[[ Patient with > 2 and < 5 siblings]]]>" & @CRLF & _
" </comment>" & @CRLF & _
" </record>" & @CRLF & _
" <record>" & @CRLF & _
" <name>Jane</name>" & @CRLF & _
" <surname>Doe</surname>" & @CRLF & _
" <dob>2001-02-01</dob>" & @CRLF & _
" <comment>" & @CRLF & _
" <![CDATA[[ Patient with > 2 siblings ]]]>" & @CRLF & _
" </comment>" & @CRLF & _
" </record>" & @CRLF & _
"</records>"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)