import Foundation
let pattern = #"\[CDATA\[\[[^]*?]]>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<records>
<record>
<name>Jon</name>
<surname>Doe</surname>
<dob>2001-02-01</dob>
<comment>
<![CDATA[[ Patient with > 2 and < 5 siblings]]]>
</comment>
</record>
<record>
<name>Jane</name>
<surname>Doe</surname>
<dob>2001-02-01</dob>
<comment>
<![CDATA[[ Patient with > 2 siblings ]]]>
</comment>
</record>
</records>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)