re = /\[CDATA\[\[[^]*?]]>/m
str = '<records>
<record>
<name>Jon</name>
<surname>Doe</surname>
<dob>2001-02-01</dob>
<comment>
<![CDATA[[ Patient with > 2 and < 5 siblings]]]>
</comment>
</record>
<record>
<name>Jane</name>
<surname>Doe</surname>
<dob>2001-02-01</dob>
<comment>
<![CDATA[[ Patient with > 2 siblings ]]]>
</comment>
</record>
</records>'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result