using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"title=""[\s\S]*?""";
string substitution = @"";
string input = @"<a href=""#"" title=""<table border=\"0\" width=\"100%\" cellspacing=\"0\" cellpadding=\"0\">
<tbody>
<tr>
<td colspan=\"2\" align=\"center\" valign=\"top\"></td>
</tr>
<tr>
<td valign=\"top\" width=\"50%\">
table content
</td>
<td valign=\"top\" width=\"50%\">
table content
</td>
</tr>
</tbody>
</table>"">Link Title</a>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}