import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "title=\"[\\s\\S]*?\"";
final String string = "<a href=\"#\" title=\"<table border=\\"0\\" width=\\"100%\\" cellspacing=\\"0\\" cellpadding=\\"0\\">\n"
+ " <tbody>\n"
+ " <tr>\n"
+ " <td colspan=\\"2\\" align=\\"center\\" valign=\\"top\\"></td>\n"
+ " </tr>\n"
+ " <tr>\n"
+ " <td valign=\\"top\\" width=\\"50%\\">\n"
+ " table content\n"
+ " </td>\n"
+ " <td valign=\\"top\\" width=\\"50%\\">\n"
+ " table content\n"
+ " </td>\n"
+ " </tr>\n"
+ " </tbody>\n"
+ "</table>\">Link Title</a>";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}