use strict;
my $str = '<a href="#" title="<table border=\\"0\\" width=\\"100%\\" cellspacing=\\"0\\" cellpadding=\\"0\\">
<tbody>
<tr>
<td colspan=\\"2\\" align=\\"center\\" valign=\\"top\\"></td>
</tr>
<tr>
<td valign=\\"top\\" width=\\"50%\\">
table content
</td>
<td valign=\\"top\\" width=\\"50%\\">
table content
</td>
</tr>
</tbody>
</table>">Link Title</a>';
my $regex = qr/title="[\s\S]*?"/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";