const regex = /title="[\s\S]*?"/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('title="[\\s\\S]*?"', '')
const str = `<a href="#" title="<table border=\\"0\\" width=\\"100%\\" cellspacing=\\"0\\" cellpadding=\\"0\\">
<tbody>
<tr>
<td colspan=\\"2\\" align=\\"center\\" valign=\\"top\\"></td>
</tr>
<tr>
<td valign=\\"top\\" width=\\"50%\\">
table content
</td>
<td valign=\\"top\\" width=\\"50%\\">
table content
</td>
</tr>
</tbody>
</table>">Link Title</a>`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);