#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)^'(\d)+':\s+(.+)$"
Local $sString = "'1': '-'" & @CRLF & _
"'2': CompanyA; 100EUR/Std" & @CRLF & _
"'3': Company2; 100EUR/Std" & @CRLF & _
"'4': Company B ; 155EUR/Std"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")