package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mx)^'(\d)+':\s+(.+)$`)
var str = `'1': '-'
'2': CompanyA; 100EUR/Std
'3': Company2; 100EUR/Std
'4': Company B ; 155EUR/Std`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}