import re
regex = re.compile(r"""
^'(\d)+':\s+(.+)$
""", flags=re.MULTILINE | re.VERBOSE)
test_str = ("'1': '-'\n"
"'2': CompanyA; 100EUR/Std\n"
"'3': Company2; 100EUR/Std\n"
"'4': Company B ; 155EUR/Std")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")