import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^'(\\d)+':\\s+(.+)$";
final String string = "'1': '-'\n"
+ "'2': CompanyA; 100EUR/Std\n"
+ "'3': Company2; 100EUR/Std\n"
+ "'4': Company B ; 155EUR/Std";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}