#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)^.*?bananas.*(*SKIP)(*FAIL)|apples|oranges"
Local $sString = "only apples" & @CRLF & _
"only oranges" & @CRLF & _
"only bananas" & @CRLF & _
"bananas and apples and oranges" & @CRLF & _
"apples and bananas and oranges" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")