// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?im)^.*?bananas.*(*SKIP)(*FAIL)|apples|oranges").unwrap();
let string = "only apples
only oranges
only bananas
bananas and apples and oranges
apples and bananas and oranges
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}