$re = '/^.*?bananas.*(*SKIP)(*FAIL)|apples|oranges/im';
$str = 'only apples
only oranges
only bananas
bananas and apples and oranges
apples and bananas and oranges
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);