using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*?bananas.*(*SKIP)(*FAIL)|apples|oranges";
string input = @"only apples
only oranges
only bananas
bananas and apples and oranges
apples and bananas and oranges
";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}