const regex = /^.*?bananas.*(*SKIP)(*FAIL)|apples|oranges/gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.*?bananas.*(*SKIP)(*FAIL)|apples|oranges', 'gim')
const str = `only apples
only oranges
only bananas
bananas and apples and oranges
apples and bananas and oranges
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}