re = /^.*?bananas.*(*SKIP)(*FAIL)|apples|oranges/im
str = 'only apples
only oranges
only bananas
bananas and apples and oranges
apples and bananas and oranges
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end