package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)^.*?bananas.*(*SKIP)(*FAIL)|apples|oranges`)
var str = `only apples
only oranges
only bananas
bananas and apples and oranges
apples and bananas and oranges
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}