#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\/b-\d+)(.+)(?!View\%20All)"
Local $sString = "http://www.foo.com/bar/b-12312903?sName=View%20All" & @CRLF & _
"http://www.foo.com/bar/b-832173712873?sName=View%20All" & @CRLF & _
"http://www.foo.com/bar/b-1208313109283129" & @CRLF & _
"http://www.foo.com/bar/b-2198123371239489?adCell=W3"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)