import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\/b-\\d+)(.+)(?!View\\%20All)";
final String string = "http://www.foo.com/bar/b-12312903?sName=View%20All\n"
+ "http://www.foo.com/bar/b-832173712873?sName=View%20All\n"
+ "http://www.foo.com/bar/b-1208313109283129\n"
+ "http://www.foo.com/bar/b-2198123371239489?adCell=W3";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}