using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\/b-\d+)(.+)(?!View\%20All)";
string substitution = @"";
string input = @"http://www.foo.com/bar/b-12312903?sName=View%20All
http://www.foo.com/bar/b-832173712873?sName=View%20All
http://www.foo.com/bar/b-1208313109283129
http://www.foo.com/bar/b-2198123371239489?adCell=W3";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}