re = /(\/b-\d+)(.+)(?!View\%20All)/m
str = 'http://www.foo.com/bar/b-12312903?sName=View%20All
http://www.foo.com/bar/b-832173712873?sName=View%20All
http://www.foo.com/bar/b-1208313109283129
http://www.foo.com/bar/b-2198123371239489?adCell=W3'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result