const regex = /(\/b-\d+)(.+)(?!View\%20All)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\\/b-\\d+)(.+)(?!View\\%20All)', 'gm')
const str = `http://www.foo.com/bar/b-12312903?sName=View%20All
http://www.foo.com/bar/b-832173712873?sName=View%20All
http://www.foo.com/bar/b-1208313109283129
http://www.foo.com/bar/b-2198123371239489?adCell=W3`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);