#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<=\V)\v(?!\v|\h\h|\t)"
Local $sString = "asd" & @CRLF & _
"asd" & @CRLF & _
"asd" & @CRLF & _
"asd" & @CRLF & _
"asd" & @CRLF & _
"" & @CRLF & _
"asd" & @CRLF & _
"asd" & @CRLF & _
"asd" & @CRLF & _
"asd" & @CRLF & _
"asd" & @CRLF & _
"" & @CRLF & _
"asd"
Local $sSubst = " "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)