import Foundation
let pattern = #"(?<=\V)\v(?!\v|\h\h|\t)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
asd
asd
asd
asd
asd
asd
asd
asd
asd
asd
asd
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #" "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)