re = /(?<=\V)\v(?!\v|\h\h|\t)/m
str = 'asd
asd
asd
asd
asd
asd
asd
asd
asd
asd
asd'
subst = ' '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result