#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(?!(.*?C){2})[ABC]{3}"
Local $sString = "ABC" & @CRLF & _
"ACB" & @CRLF & _
"CBA" & @CRLF & _
"BCA" & @CRLF & _
"AAB" & @CRLF & _
"ABA" & @CRLF & _
"BAA" & @CRLF & _
"AAC" & @CRLF & _
"ACA" & @CRLF & _
"CAA" & @CRLF & _
"ABB" & @CRLF & _
"BAB" & @CRLF & _
"BBA" & @CRLF & _
"BBB" & @CRLF & _
"CCC" & @CRLF & _
"CCA" & @CRLF & _
"CAC" & @CRLF & _
"ACC" & @CRLF & _
"CCB" & @CRLF & _
"CBC" & @CRLF & _
"BCC" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")