import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?!(.*?C){2})[ABC]{3}";
final String string = "ABC\n"
+ "ACB\n"
+ "CBA\n"
+ "BCA\n"
+ "AAB\n"
+ "ABA\n"
+ "BAA\n"
+ "AAC\n"
+ "ACA\n"
+ "CAA\n"
+ "ABB\n"
+ "BAB\n"
+ "BBA\n"
+ "BBB\n"
+ "CCC\n"
+ "CCA\n"
+ "CAC\n"
+ "ACC\n"
+ "CCB\n"
+ "CBC\n"
+ "BCC\n\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}