const regex = new RegExp('(?!(.*?C){2})[ABC]{3}', 'gi')
const str = `ABC
ACB
CBA
BCA
AAB
ABA
BAA
AAC
ACA
CAA
ABB
BAB
BBA
BBB
CCC
CCA
CAC
ACC
CCB
CBC
BCC
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}