#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(?!<a href.*$)(http)?(s)?(:\/\/)?(([-\w]+\.)+([^\s]+)+[^,.\s])"
Local $sString = "http://www.example.com" & @CRLF & _
"https://www.example.com" & @CRLF & _
"www.example.com" & @CRLF & _
"<a href="http://www.example.com">http://www.example.com</a>"
Local $sSubst = "<a href="http$2://$4">$1$2$3$4</a>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)