const regex = /^(?!<a href.*$)(http)?(s)?(:\/\/)?(([-\w]+\.)+([^\s]+)+[^,.\s])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!<a href.*$)(http)?(s)?(:\\\/\\\/)?(([-\\w]+\\.)+([^\\s]+)+[^,.\\s])', 'gm')
const str = `http://www.example.com
https://www.example.com
www.example.com
<a href="http://www.example.com">http://www.example.com</a>`;
const subst = `<a href="http$2://$4">$1$2$3$4</a>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);