$re = '/^(?!<a href.*$)(http)?(s)?(:\/\/)?(([-\w]+\.)+([^\s]+)+[^,.\s])/m';
$str = 'http://www.example.com
https://www.example.com
www.example.com
<a href="http://www.example.com">http://www.example.com</a>';
$subst = "<a href=\"http$2://$4\">$1$2$3$4</a>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;