use strict;
my $str = 'http://www.example.com
https://www.example.com
www.example.com
<a href="http://www.example.com">http://www.example.com</a>';
my $regex = qr/^(?!<a href.*$)(http)?(s)?(:\/\/)?(([-\w]+\.)+([^\s]+)+[^,.\s])/mp;
my $subst = '<a href="http$2://$4">$1$2$3$4</a>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";