import re
regex = re.compile(r"^(?!<a href.*$)(http)?(s)?(:\/\/)?(([-\w]+\.)+([^\s]+)+[^,.\s])", flags=re.MULTILINE)
test_str = ("http://www.example.com\n"
"https://www.example.com\n"
"www.example.com\n"
"<a href=\"http://www.example.com\">http://www.example.com</a>")
subst = "<a href=\"http$2://$4\">$1$2$3$4</a>"
result = regex.sub(subst, test_str)
if result:
print(result)