import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!<a href.*$)(http)?(s)?(:\\/\\/)?(([-\\w]+\\.)+([^\\s]+)+[^,.\\s])";
final String string = "http://www.example.com\n"
+ "https://www.example.com\n"
+ "www.example.com\n"
+ "<a href=\"http://www.example.com\">http://www.example.com</a>";
final String subst = "<a href=\"http$2://$4\">$1$2$3$4</a>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}