using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!<a href.*$)(http)?(s)?(:\/\/)?(([-\w]+\.)+([^\s]+)+[^,.\s])";
string substitution = @"<a href=""http$2://$4"">$1$2$3$4</a>";
string input = @"http://www.example.com
https://www.example.com
www.example.com
<a href=""http://www.example.com"">http://www.example.com</a>";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}