$re = '/[\t\p{Zs}]+/';
$str = 'ABCD A M@L 79
BGDA F D@L 89';
$subst = ",";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;