import Foundation
let pattern = #"[\t\p{Zs}]+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
ABCD A M@L 79
BGDA F D@L 89
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #","#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)