# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/('(?=\S)[^']*\S')|:/$1@/g;t' <<< "select ':' id, :DATA_INI, ':DATA_INI', titulo, date_format(data_criacao,'%d/%m/%Y %H:%i') str_data_criacao
from v$sugestoes
where data_criacao between :DATA_INI AND :DATA_FIM
order by data_criacao"