import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "('(?=\\S)[^']*\\S')|:";
final String string = "select ':' id, :DATA_INI, ':DATA_INI', titulo, date_format(data_criacao,'%d/%m/%Y %H:%i') str_data_criacao\n"
+ "from v$sugestoes\n"
+ "where data_criacao between :DATA_INI AND :DATA_FIM\n"
+ "order by data_criacao";
final String subst = "$1@";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}