import re
regex = re.compile(r"('(?=\S)[^']*\S')|:")
test_str = ("select ':' id, :DATA_INI, ':DATA_INI', titulo, date_format(data_criacao,'%d/%m/%Y %H:%i') str_data_criacao\n"
"from v$sugestoes\n"
"where data_criacao between :DATA_INI AND :DATA_FIM\n"
"order by data_criacao")
subst = "$1@"
result = regex.sub(subst, test_str)
if result:
print(result)