const regex = /('(?=\S)[^']*\S')|:/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\'(?=\\S)[^\']*\\S\')|:', 'g')
const str = `select ':' id, :DATA_INI, ':DATA_INI', titulo, date_format(data_criacao,'%d/%m/%Y %H:%i') str_data_criacao
from v\$sugestoes
where data_criacao between :DATA_INI AND :DATA_FIM
order by data_criacao`;
const subst = `$1@`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);