package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(({if \$var})[^}]*})\s*[^{}]*\s*{/if}`)
var str = `{if $var}
{if $var}
{if $var}
text
{else}
text *(&@$@!/\#<?>~\`.,+-_
{if $var}
any symbols
{elseif $var}
text
{else}
{if $var}{/if}
{/if}
{if $var}{/if}
{else}
text and symbols *(&@$$@!
{/if}
(({if \$var})[^}]*})\s*[^{}]*\s*{/if} // 2450 steps
(?(?=\/.?)|({if \$var}).*?)*(?={\/if}) // 1531 steps`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}