# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(({if \$var})[^}]*})\s*[^{}]*\s*{/if}"
test_str = ("{if $var}\n"
" {if $var}\n"
" {if $var} \n"
" text\n"
" {else}\n\n"
" text *(&@$@!/\\#<?>~`.,+-_\n"
" \n"
" {if $var}\n"
" any symbols\n"
" {elseif $var}\n"
" text\n"
" {else} \n"
" {if $var}{/if}\n"
" {/if}\n"
" {if $var}{/if}\n"
"{else}\n"
" text and symbols *(&@$$@!\n"
"{/if}\n\n\n\n"
"(({if \\$var})[^}]*})\\s*[^{}]*\\s*{/if} // 2450 steps\n\n\n"
"(?(?=\\/.?)|({if \\$var}).*?)*(?={\\/if}) // 1531 steps")
matches = re.search(regex, test_str, re.IGNORECASE)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.