re = /(({if \$var})[^}]*})\s*[^{}]*\s*{\/if}/i
str = '{if $var}
{if $var}
{if $var}
text
{else}
text *(&@$@!/\\#<?>~`.,+-_
{if $var}
any symbols
{elseif $var}
text
{else}
{if $var}{/if}
{/if}
{if $var}{/if}
{else}
text and symbols *(&@$$@!
{/if}
(({if \\$var})[^}]*})\\s*[^{}]*\\s*{/if} // 2450 steps
(?(?=\\/.?)|({if \\$var}).*?)*(?={\\/if}) // 1531 steps'
# Print the match result
str.match(re) do |match|
puts match.to_s
end