// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)(({if \$var})[^}]*})\s*[^{}]*\s*{/if}").unwrap();
let string = "{if $var}
{if $var}
{if $var}
text
{else}
text *(&@$@!/\\#<?>~`.,+-_
{if $var}
any symbols
{elseif $var}
text
{else}
{if $var}{/if}
{/if}
{if $var}{/if}
{else}
text and symbols *(&@$$@!
{/if}
(({if \\$var})[^}]*})\\s*[^{}]*\\s*{/if} // 2450 steps
(?(?=\\/.?)|({if \\$var}).*?)*(?={\\/if}) // 1531 steps";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}