const regex = new RegExp('(({if \\$var})[^}]*})\\s*[^{}]*\\s*{/if}', 'i')
const str = `{if \$var}
{if \$var}
{if \$var}
text
{else}
text *(&@\$@!/\\#<?>~\`.,+-_
{if \$var}
any symbols
{elseif \$var}
text
{else}
{if \$var}{/if}
{/if}
{if \$var}{/if}
{else}
text and symbols *(&@\$\$@!
{/if}
(({if \\\$var})[^}]*})\\s*[^{}]*\\s*{/if} // 2450 steps
(?(?=\\/.?)|({if \\\$var}).*?)*(?={\\/if}) // 1531 steps`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}