import Foundation
let pattern = #"(({if \$var})[^}]*})\s*[^{}]*\s*{/if}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = ##"""
{if $var}
{if $var}
{if $var}
text
{else}
text *(&@$@!/\#<?>~`.,+-_
{if $var}
any symbols
{elseif $var}
text
{else}
{if $var}{/if}
{/if}
{if $var}{/if}
{else}
text and symbols *(&@$$@!
{/if}
(({if \$var})[^}]*})\s*[^{}]*\s*{/if} // 2450 steps
(?(?=\/.?)|({if \$var}).*?)*(?={\/if}) // 1531 steps
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}