use strict;
my $str = '{if $var}
{if $var}
{if $var}
text
{else}
text *(&@$@!/\\#<?>~`.,+-_
{if $var}
any symbols
{elseif $var}
text
{else}
{if $var}{/if}
{/if}
{if $var}{/if}
{else}
text and symbols *(&@$$@!
{/if}
(({if \\$var})[^}]*})\\s*[^{}]*\\s*{/if} // 2450 steps
(?(?=\\/.?)|({if \\$var}).*?)*(?={\\/if}) // 1531 steps';
my $regex = qr~(({if \$var})[^}]*})\s*[^{}]*\s*{/if}~ip;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}