#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?x)\b(?:typedef struct|typedef|struct)\b" & @CRLF & _
"[^;{}]+" & @CRLF & _
"(?: ( \{ (?: [^{}]++ | (?1) )+ \} ) [^;]* )?" & @CRLF & _
";"
Local $sString = "" & @CRLF & _
"typedef struct SS__DD WEFGEGWEG;" & @CRLF & _
" " & @CRLF & _
"struct SS__DD WEFGEGWEG;" & @CRLF & _
" " & @CRLF & _
"typedef struct SS__DD {" & @CRLF & _
" DFBFFN *trait_method;" & @CRLF & _
" union {" & @CRLF & _
" HRTRTH *cRTNe;" & @CRLF & _
" RTHR 56J56;" & @CRLF & _
" } *SEGWEG;" & @CRLF & _
"} WEFGEGWEG; " & @CRLF & _
" " & @CRLF & _
"typedef struct SS__DD {" & @CRLF & _
" DFBFFN *trait_method;" & @CRLF & _
" union {" & @CRLF & _
" HRTRTH *cRTNe;" & @CRLF & _
" RTHR 56J56;" & @CRLF & _
" } *SEGWEG;" & @CRLF & _
"} WEFGEGWEG, WEFGE4Y45Y; " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
"typedef struct SS__DD {" & @CRLF & _
" DFBFFN *trait_method;" & @CRLF & _
" union {" & @CRLF & _
" HRTRTH *cRTNe;" & @CRLF & _
" RTHR 56J56;" & @CRLF & _
" } *SEGWEG;" & @CRLF & _
"}; " & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")